StuRa:Server/TurnKey

Aus Wiki StuRa HTW Dresden
(Weitergeleitet von TurnKey)
Wechseln zu: Navigation, Suche

initiales Initiieren[Bearbeiten]

Programm turnkey-init[Bearbeiten]

turnkey-init

Dienst turnkey-init-fence[Bearbeiten]

systemctl status turnkey-init-fence
$EDITOR /usr/lib/inithooks/firstboot.d/30turnkey-init-fence
systemctl status turnkey-init-fence
systemctl stop turnkey-init-fence

Aktualisierung[Bearbeiten]

Ermittlung der aktuellen Version[Bearbeiten]

Ausgeben des Inhaltes der Datei /etc/turnkey_version

cat /etc/turnkey_version
turnkey-nextcloud-15.2-stretch-amd64

Aktualisierung von TurnKey 15 auf TurnKey 16[Bearbeiten]

planloser erster Versuch
Beim konkreten Versuch, schlug der Versuch fehl.
Der konkrete Versuch bezog sich auf TurnKey Nextcloud.
Bei Server/Proxmox#Containerisierung für TurnKey hätte eine Server/Proxmox#Änderung der Konfiguration von Instanzen der Containerisierung von privilegiert zu unprivilegiert vorgenommen werden müssen.
Die Server/Proxmox#Änderung der Konfiguration von Instanzen der Containerisierung von privilegiert zu unprivilegiert funktionierte leider nicht richtig.
lsb_release -a
No LSB modules are available.
Distributor ID:	TurnKey
Description:	TurnKey GNU/Linux 9.13 (stretch)
Release:	9.13
Codename:	stretch
ls /etc/apt/sources.list
ls: cannot access '/etc/apt/sources.list': No such file or directory
ls /etc/apt/sources.list.d/
php.list  security.sources.list  sources.list
sed -i 's/stretch/buster/g' /etc/apt/sources.list.d/*.list
apt update

W: GPG error: http://archive.turnkeylinux.org/debian buster-security Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 9F3DF15B48406D14
E: The repository 'http://archive.turnkeylinux.org/debian buster-security Release' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: GPG error: http://archive.turnkeylinux.org/debian buster Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 1C7082DDE779614F
E: The repository 'http://archive.turnkeylinux.org/debian buster Release' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
apt-key adv --keyserver http://keyserver.ubuntu.com:80 --recv-keys C2518248EEA14886
Executing: /tmp/apt-key-gpghome.WU6BFi2Coo/gpg.1.sh --keyserver http://keyserver.ubuntu.com:80 --recv-keys C2518248EEA14886
gpg: failed to start the dirmngr '/usr/bin/dirmngr': No such file or directory
gpg: connecting dirmngr at '/tmp/apt-key-gpghome.WU6BFi2Coo/S.dirmngr' failed: No such file or directory
gpg: keyserver receive failed: No dirmngr
apt -y install dirmngr


apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 9F3DF15B48406D14
Executing: /tmp/apt-key-gpghome.sD5dI4aGv9/gpg.1.sh --keyserver keyserver.ubuntu.com --recv-keys 9F3DF15B48406D14
gpg: key E3A68C7D36ED4595: public key "TurnKey GNU/Linux Buster Security apt repo (GPG signing key for TurnKey Linux Buster Security apt repository) <release-buster-security@turnkeylinux.org>" imported
gpg: Total number processed: 1
gpg:               imported: 1
apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 1C7082DDE779614F
Executing: /tmp/apt-key-gpghome.aDcuorW788/gpg.1.sh --keyserver keyserver.ubuntu.com --recv-keys 1C7082DDE779614F
gpg: key EF81D7D8EE49B5E5: public key "TurnKey GNU/Linux Buster Main apt repo (GPG signing key for TurnKey Linux Buster Main apt repository) <release-buster-main@turnkeylinux.org>" imported
gpg: Total number processed: 1
gpg:               imported: 1
apt update
Hit:1 http://security.debian.org buster/updates InRelease
Hit:2 http://deb.debian.org/debian buster InRelease                             
Hit:3 https://packages.sury.org/php buster InRelease                                 
Ign:4 http://archive.turnkeylinux.org/debian buster-security InRelease               
Ign:5 http://archive.turnkeylinux.org/debian buster InRelease
Hit:6 http://archive.turnkeylinux.org/debian buster-security Release
Hit:8 http://archive.turnkeylinux.org/debian buster Release                          
Reading package lists... Done                             
Building dependency tree       
Reading state information... Done
450 packages can be upgraded. Run 'apt list --upgradable' to see them.
apt -y dist-upgrade

Installing new version of config file /etc/bash.bashrc ...

Configuration file '/etc/skel/.profile'
 ==> Modified (by you or by a script) since installation.
 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      Z     : start a shell to examine the situation
 The default action is to keep your current version.
*** .profile (Y/I/N/O/D/Z) [default=N] ? 

Setting up login (1:4.5-1.1) ...

Configuration file '/etc/securetty'
 ==> Modified (by you or by a script) since installation.
 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      Z     : start a shell to examine the situation
 The default action is to keep your current version.
*** securetty (Y/I/N/O/D/Z) [default=N] ? 

Configuration file '/etc/crontab'
 ==> Modified (by you or by a script) since installation.
 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      Z     : start a shell to examine the situation
 The default action is to keep your current version.
*** crontab (Y/I/N/O/D/Z) [default=N] ? 

Installing new version of config file /etc/init.d/procps ...

Configuration file '/etc/sysctl.conf'
 ==> Modified (by you or by a script) since installation.
 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      Z     : start a shell to examine the situation
 The default action is to keep your current version.
*** sysctl.conf (Y/I/N/O/D/Z) [default=N] ? 

Setting up udhcpc (1:1.30.1-4) ...

Configuration file '/etc/udhcpc/default.script'
 ==> Modified (by you or by a script) since installation.
 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      Z     : start a shell to examine the situation
 The default action is to keep your current version.
*** default.script (Y/I/N/O/D/Z) [default=N] ? 

Setting up stunnel4 (3:5.50-3) ...

Configuration file '/etc/default/stunnel4'
 ==> Modified (by you or by a script) since installation.
 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      Z     : start a shell to examine the situation
 The default action is to keep your current version.
*** stunnel4 (Y/I/N/O/D/Z) [default=N] ? 

Setting up vim-tiny (2:8.1.0875-5) ...

Configuration file '/etc/vim/vimrc.tiny'
 ==> Modified (by you or by a script) since installation.
 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      Z     : start a shell to examine the situation
 The default action is to keep your current version.
*** vimrc.tiny (Y/I/N/O/D/Z) [default=N] ? 

Package configuration                                                                                                 
                                                                                                                      
  ┌──────────────────────────────────────────┤ Configuring localepurge ├───────────────────────────────────────────┐  
  │ The localepurge package will remove all locale files from the system except those that you select here.        │  
  │                                                                                                                │  
  │ When selecting the locale corresponding to your language and country code (such as "de_DE", "de_CH", "it_IT",  │  
  │ etc.) it is recommended to choose the two-character entry ("de", "it", etc.) as well.                          │  
  │                                                                                                                │  
  │ Entries from /etc/locale.gen will be preselected if no prior configuration has been successfully completed.    │  
  │                                                                                                                │  
  │ Locale files to keep on this system:                                                                           │  
  │                                                                                                                │  
  │    [ ] da                                                                                                  ↑   │  
  │    [ ] da_DK                                                                                               ▮   │  
  │    [ ] da_DK.UTF-8                                                                                         ▒   │  
  │    [ ] de                                                                                                  ▒   │  
  │    [ ] de_AT                                                                                               ▒   │  
  │    [ ] de_AT@euro                                                                                          ▒   │  
  │    [ ] de_AT.UTF-8                                                                                         ↓   │  
  │                                                                                                                │  
  │                                                                                                                │  
  │                                                     <Ok>                                                       │  
  │                                                                                                                │  
  └────────────────────────────────────────────────────────────────────────────────────────────────────────────────┘  
                                                                                                                      
                                                                                                                      
<Ok>
                                                                                                                      
  ┌──────────────────────────────────────────┤ Configuring localepurge ├──────────────────────────────────────────┐   
  │                                                                                                               │   
  │ dpkg supports --path-exclude and --path-include options to filter files from packages being installed.        │   
  │                                                                                                               │   
  │ Please see /usr/share/doc/localepurge/README.dpkg-path for more information about this feature. It can be     │   
  │ enabled (or disabled) later by running "dpkg-reconfigure localepurge".                                        │   
  │                                                                                                               │   
  │ This option will become active for packages unpacked after localepurge has been (re)configured. Packages      │   
  │ installed or upgraded together with localepurge may (or may not) be subject to the previous configuration of  │   
  │ localepurge.                                                                                                  │   
  │                                                                                                               │   
  │ Use dpkg --path-exclude?                                                                                      │   
  │                                                                                                               │   
  │                                <Yes>                                   <No>                                   │   
  │                                                                                                               │   
  └───────────────────────────────────────────────────────────────────────────────────────────────────────────────┘   
                                                                                                                      
                                                                                                                      
                                                                                                                      
                                                                                                                      
                                                                                                                      
<No>
Package configuration                                                                                                 
                                                                                                                      
                                                                                                                      
                                                                                                                      
                                                                                                                      
     ┌───────────────────────────────────────┤ Configuring localepurge ├───────────────────────────────────────┐      
     │ locale.nopurge: A new version (/etc/locale.nopurge.44450) of configuration file /etc/locale.nopurge is  │      
     │ available, but the version installed currently has been locally modified.                               │      
     │                                                                                                         │      
     │ What do you want to do about modified configuration file locale.nopurge?                                │      
     │                                                                                                         │      
     │                          install the package maintainer's version                                       │      
     │                          keep the local version currently installed                                     │      
     │                          show the differences between the versions                                      │      
     │                          show a side-by-side difference between the versions                            │      
     │                          start a new shell to examine the situation                                     │      
     │                                                                                                         │      
     │                                                                                                         │      
     │                                                 <Ok>                                                    │      
     │                                                                                                         │      
     └─────────────────────────────────────────────────────────────────────────────────────────────────────────┘      
                                                                                                                      
                                                                                                                      
                                                                                                                      
                                                                                                                      
                                                                                                                      
keep the local version currently installed         

Installing new version of config file /etc/init.d/redis-server ...

Configuration file '/etc/redis/redis.conf'
 ==> Modified (by you or by a script) since installation.
 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      Z     : start a shell to examine the situation
 The default action is to keep your current version.
*** redis.conf (Y/I/N/O/D/Z) [default=N] ? 

Package configuration                                                                                                 
                                                                                                                      
                                                                                                                      
                                                                                                                      
    ┌──────────────────────────────────────┤ Configuring openssh-server ├───────────────────────────────────────┐     
    │ A new version (/tmp/fileMxBttW) of configuration file /etc/ssh/sshd_config is available, but the version  │     
    │ installed currently has been locally modified.                                                            │     
    │                                                                                                           │     
    │ What do you want to do about modified configuration file sshd_config?                                     │     
    │                                                                                                           │     
    │                           install the package maintainer's version                                        │     
    │                           keep the local version currently installed                                      │     
    │                           show the differences between the versions                                       │     
    │                           show a side-by-side difference between the versions                             │     
    │                           show a 3-way difference between available versions                              │     
    │                           do a 3-way merge between available versions                                     │     
    │                           start a new shell to examine the situation                                      │     
    │                                                                                                           │     
    │                                                                                                           │     
    │                                                  <Ok>                                                     │     
    │                                                                                                           │     
    └───────────────────────────────────────────────────────────────────────────────────────────────────────────┘     
                                                                                                                      
                                                                                                                      
                                                                                                                      
                                                                                                                      
keep the local version currently installed          

Installing new version of config file /etc/etckeeper/commit.d/99push ...

Configuration file '/etc/etckeeper/etckeeper.conf'
 ==> Modified (by you or by a script) since installation.
 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      Z     : start a shell to examine the situation
 The default action is to keep your current version.
*** etckeeper.conf (Y/I/N/O/D/Z) [default=N] ? 

apt -y autoremove

apt -y dist-upgrade

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
reboot
apt -y autoremove

All packages are up to date.


Zertifikat[Bearbeiten]

Zertifikat Let's Encrypt[Bearbeiten]

/usr/bin/dehydrated --register --accept-terms

confconsole

fail!

https://github.com/turnkeylinux/confconsole#upgrade-to-v1-0-0

fail!

https://github.com/turnkeylinux/confconsole/releases/tag/v1.1.2

#How to install/update

works!

Anwendungen[Bearbeiten]

Anwendung Nextcloud[Bearbeiten]

StuRa:Server/Nextcloud#TurnKey

Systeme[Bearbeiten]

System Proxmox[Bearbeiten]

Server/Proxmox#Containerisierung für TurnKey