Diskussion:Server/srs1

Aus Wiki StuRa HTW Dresden
Wechseln zu: Navigation, Suche

post deployment installing

  • zsh
  • tmux

post installation debugging

Seit der Migration im Sommer 2017 ist die Website (Plone) arg langsam. Der für den Betrieb maßgebliche Prozess benötigt arg (mehr) Rechenleistung (etwa sichtbar als (W)CPU in top).

(Dokumentation von) Tests und Maßnahmen (des Versuches das Problem zu beheben) sind kurz in den nachfolgenden Abschnitten benannt.

einzelne Instanz Plone für die Website

Konfiguration
Sichten, Prüfen, Testen
  • Erweiterungen
    • Dexterity Inhaltstypen
    • Unterstützung für Diazo Designs
    • Dropdown menu
    • HTTP caching support
    • Unterstützung für Arbeitskopien
pdftotext
Unable to find binary "pdftotext" in /sbin:/bin:/usr/sbin:/usr/bin
pkg install -y xpdf
ln -s /usr/local/libexec/xpdf/pdftotext /usr/bin/pdftotext

fixed!

wvHtml
MissingBinary: Unable to find binary "wvHtml" in /sbin:/bin:/usr/sbin:/usr/bin
pkg install -y wv
ln -s /usr/local/bin/wvHtml /usr/bin/wvHtml
.../stura/ref/verwaltung/mails/lists/listinfo
An error was encountered while publishing this resource.
Cannot locate object

???

zope management foo
/portal_catalog/manage_catalogAdvanced
  • Update Catalog
/portal_catalog/manage_catalogAdvanced
  • Clear and Rebuild
keine Verbesserung wahrgenommen (nicht schneller und falsche Referenzen gibt es immer noch)
/portal_javascripts/manage_jsForm
  • Development mode ausgeschaltet
    wozu auch immer zur Hölle das angeschaltet war

gesamte Instanz Plone in Zope im Ganzen

/Control_Panel/DebugInfo/manage_main


zusätzlicher Vorgang zur Migration der Kommentare für die Bereitstellung der Funktionalität für Kommentare

Kurz nach der Migration fiel auf, dass die Funktion für Kommentar - obwohl sie angeschaltet war - nicht in Betrieb war. Grund dafür war, dass es einem eigenständigen Vorgang für das Migrieren der Kommentare bedarf.

http://www.stura.htw-dresden.de:8080/Plone/@@comment-migration

Found 13924 content objects.
Found 0 Discussion Item objects.
Found 0 old discussion items.
Found 1119 plone.app.discussion comments.


Start comment migration.


Comment migration finished.


0 of 0 comments migrated.

Nach einem Neustart vom Dienst Plone (service plone restart) waren alle früheren Kommentare da und es konnten nun neue Kommentare hinzugefügt werden.


Module zope.tales.tales, line 696, in evaluate
URL: file:/usr/local/lib/python2.7/site-packages/Products/Archetypes/skins/archetypes/widgets/rich.pt
Line 21, Column 12
Expression: <PathExpr standard:u'accessor'>
Names:
{'container': <PloneSite at /Plone>,
 'context': <ATDocument at /Plone/members/PaulRiegel/taste>,
 'default': <object object at 0x80069e580>,
 'here': <ATDocument at /Plone/members/PaulRiegel/taste>,
 'loop': {},
 'nothing': None,
 'options': {'args': ()},
 'repeat': <Products.PageTemplates.Expressions.SafeMapping object at 0x8356f1cb0>,
 'request': <HTTPRequest, URL=http://www.stura.htw-dresden.de/members/PaulRiegel/taste/document_view>,
 'root': <Application at >,
 'template': <FSPageTemplate at /Plone/document_view used for /Plone/members/PaulRiegel/taste>,
 'traverse_subpath': [],
 'user': <PloneUser 'PaulRiegel'>}


ValueError: Invalid IPv6 URL


pkg install -y py27-html5lib

customized dehydrated (Server/Transport Layer Security#Probleme bei Plone)

cd /usr/local/etc/apache24/ && ./dehydrated_script.sh && cd -
Performing sanity check on apache24 configuration:
Syntax OK
Stopping apache24.
Waiting for PIDS: 5771.
Performing sanity check on apache24 configuration:
Syntax OK
Starting apache24.
# INFO: Using main config file /usr/local/etc/dehydrated/config
Processing www.stura.htw-dresden.de with alternative names: stura-dresden.de www.stura-dresden.de stura.htw-dresden.de
 + Checking domain name(s) of existing cert... unchanged.
 + Checking expire date of existing cert...
 + Valid till Nov 26 10:04:45 2018 GMT (Less than 30 days). Renewing!
 + Signing domains...
 + Generating private key...
 + Generating signing request...
 + Requesting challenge for www.stura.htw-dresden.de...
 + Requesting challenge for stura-dresden.de...
 + Requesting challenge for www.stura-dresden.de...
 + Requesting challenge for stura.htw-dresden.de...
 + Responding to challenge for www.stura.htw-dresden.de...
 + Challenge is valid!
 + Responding to challenge for stura-dresden.de...
 + Challenge is valid!
 + Responding to challenge for www.stura-dresden.de...
 + Challenge is valid!
 + Responding to challenge for stura.htw-dresden.de...
 + Challenge is valid!
 + Requesting certificate...
 + Checking certificate...
 + Done!
 + Creating fullchain.pem...
 + Done!
Performing sanity check on apache24 configuration:
Syntax OK
Stopping apache24.
Waiting for PIDS: 66646.
Performing sanity check on apache24 configuration:
Syntax OK
Starting apache24.
/

Kommentar-foo angemacht!

https://www.stura.htw-dresden.de/@@discussion-settings

com.web@stura.…

Paul 01:52, 30. Nov. 2019 (CET)

(vorgeschaltete eigenständige) Instanz proxy für zeitgemäßes TLS läuft wegen (versehentlich nicht ausgeschalteten) logging über

df -h /
Filesystem      Size  Used Avail Use% Mounted on
/dev/rbd5       2.0G  1.8G   71M  97% /
ls -al /var/log/nginx/
total 621996
drwxr-xr-x  2 root     adm       4096 Aug 19 14:47 .
drwxr-xr-x 11 root     root      4096 Aug 19 15:07 ..
-rw-r-----  1 www-data adm  628081770 Oct  2 14:44 access.log
-rw-r--r--  1 root     root         0 Oct  2 12:35 adminer-error.log
-rw-r-----  1 www-data adm    8821607 Oct  2 14:43 error.log
einstweilige Behebung
rm /var/log/nginx/access.log

reboot

df -h /
Filesystem      Size  Used Avail Use% Mounted on
/dev/rbd5       2.0G  1.2G  610M  67% /
nano /etc/nginx/nginx.conf

        ##
        # Logging Settings
        ##

#       access_log /var/log/nginx/access.log;
        access_log off;
#       error_log /var/log/nginx/error.log;
        error_log off;

rm /var/log/nginx/error.log

(vorgeschaltete eigenständige) Instanz proxy für zeitgemäßes TLS lässt das Hochladen von großen Dateien nicht zu

nano /etc/nginx/nginx.conf

client_max_body_size 1G;

plone 4 auf debian 10 2021

in Anlehnung an https://docs.plone.org/4/en/manage/installing/installation.html

apt -y install python-setuptools python-dev build-essential libssl-dev libxml2-dev libxslt1-dev libbz2-dev libz-dev

libjpeg62-dev, wie bei Plone beschrieben, gibt es nicht. Aber es gibt libjpeg62-turbo-dev.

apt -y install libjpeg62-turbo-dev
apt -y install libreadline-dev wv poppler-utils
cd /tmp/
wget --no-check-certificate https://launchpad.net/plone/4.3/4.3.9/+download/Plone-4.3.9-UnifiedInstaller.tgz
tar -xf Plone-4.3.9-UnifiedInstaller.tgz
cd Plone-4.3.9-UnifiedInstaller/
./install.sh standalone
apt -y install sudo
./install.sh standalone
/usr/local/Plone/zinstance
bin/buildout
Installing instance.
/usr/local/Plone/buildout-cache/eggs/setuptools-20.1.1-py2.7.egg/pkg_resources/__init__.py:192: RuntimeWarning: You have iterated over the result of pkg_resources.parse_version. This is a legacy behavior which is inconsistent with the new version class introduced in setuptools 8.0. In most cases, conversion to a tuple is unnecessary. For comparison of versions, sort the Version instances directly. If you have another use case requiring the tuple, please file a bug with the setuptools project describing that need.
  stacklevel=1,
Download error on http://download.zope.org/ppix/: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:727) -- Some packages may not be found!
Download error on http://download.zope.org/distribution/: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:727) -- Some packages may not be found!
Download error on http://effbot.org/downloads: hostname 'effbot.org' doesn't match either of 'www.github.com', '*.github.com', 'github.com', '*.github.io', 'github.io', '*.githubusercontent.com', 'githubusercontent.com' -- Some packages may not be found!
Getting distribution for 'lxml==2.3.6'.
Building lxml version 2.3.6.
Building without Cython.
Using build configuration of libxslt 1.1.32
x86_64-linux-gnu-gcc: fatal error: Killed signal terminated program cc1
compilation terminated.
error: Setup script exited with error: command 'x86_64-linux-gnu-gcc' failed with exit status 1
An error occurred when trying to install lxml 2.3.6. Look above this message for any errors that were output by easy_install.
While:
  Installing instance.
  Getting distribution for 'lxml==2.3.6'.
Error: Couldn't install: lxml 2.3.6

?

apt -y install python-lxml