Bearbeiten von „StuRa:Install-Party/FreeBSD

Zur Navigation springen Zur Suche springen
Warnung: Du bist nicht angemeldet. Deine IP-Adresse wird bei Bearbeitungen öffentlich sichtbar. Melde dich an oder erstelle ein Benutzerkonto, damit Bearbeitungen deinem Benutzernamen zugeordnet werden. Ein eigenes Benutzerkonto hat eine ganze Reihe von Vorteilen.

Die Bearbeitung kann rückgängig gemacht werden. Bitte prüfe den Vergleich unten, um sicherzustellen, dass du dies tun möchtest, und veröffentliche dann unten deine Änderungen, um die Bearbeitung rückgängig zu machen.

Aktuelle Version Dein Text
Zeile 34: Zeile 34:
  match “system” “ACPI”;
  match “system” “ACPI”;
  match “subsystem” “IBM”;
  match “subsystem” “IBM”;
  match “notify” “0×04";
  match “notify” “0×04?;
  action “/usr/sbin/acpiconf -s 3";
  action “/usr/sbin/acpiconf -s 3?;
  };
  };


Zeile 88: Zeile 88:
# vim /boot/loader.conf
# vim /boot/loader.conf


legal.intel_wpi.license_ack=1
  if_wpi_load=”YES”
wpifw_load="YES"
  if_wpi_load="YES"
firmware_load="YES"
wlan_amrr_load="YES"


Next, I generate my WPA passphrase and modify the wpa_supplicant file which holds WPA configuration:
Next, I generate my WPA passphrase and modify the wpa_supplicant file which holds WPA configuration:
Zeile 109: Zeile 105:
  proto=WPA
  proto=WPA
  psk=PREVIOUSLY_GENERATED_KEY
  psk=PREVIOUSLY_GENERATED_KEY
}
# join free open networks
network={
        key_mgmt=NONE
        priority=0
  }
  }


I add scan_ssid=1 because my essid is hidden (no broadcast). Wireless is now setup.
I add scan_ssid=1 because my essid is hidden (no broadcast). Wireless is now setup.


Don't forget to startup your physical and virtual wlan adapter.
===== eduroam =====
Meine ''/etc/[http://www.freebsd.org/cgi/man.cgi?query=wpa_supplicant.conf&apropos=0&sektion=5&manpath=FreeBSD+9-current&arch=default&format=html wpa_supplicant.conf]'' hat (anteilig) folgenden Eintrag:
<code><pre>
ctrl_interface=/var/run/wpa_supplicant
network={
ssid="eduroam"
## priority
### Mein Halbwissen: Kann benutzt werden, um die Priorität des Netzwerkes festzulegen. Die Priorität legt fest,
### wie die Reihenfolge der Netzwerke ist, die zum erfolgreichen Verbinden mit einem Netzwerk abgearbeitet wird.
### Jedoch müsste es auch auskommentieren (mit # als erstes Zeichen der Zeile) funktionieren.
### Die Priorität wird bei PC-BSD automatisch mit eingetragen. Der Wert beim Eintrag des ersten Netzwerkes
### beträgt ''145''. Die kommenden erhalten den ''geringsten Wert'' -1''.
priority=145
## scan_ssid
### Mein Halbwissen: Kann benutzt werden, um die Suche nach dem Netzwerk festzulegen. Der Wert ''0'' lehnt das ab.
### Der Wert ''1'' lässt das zu. Jedoch müsste es auch auskommentieren (mit # als erstes Zeichen der Zeile)
### funktionieren.
### Das Scanning wird bei PC-BSD automatisch mit ''1'' eingetragen.
scan_ssid=1
proto=WPA
key_mgmt=WPA-EAP
eap=TTLS
identity="XXXXX@htw-dresden.de"
## anonymous_identity
### Mein Halbwissen: Kann fuer das Tunneln mit EAP benutzt werden.
### Wahrscheinlich bedarf es der Angabe der anonymen Identitaet nur bei der Anwendung an anderen Hochschulen.
## anonymous_identity="anonymous@domain"
password="XXXXX"
## ca_cert
### Mein Halbwissen: Definiert den Pfad mit Dateiname des (lokalen) Ablageortes zum notwendigen Zertifikat.
### Offensichtlich bedarf es (aber) keinem Zertifikat. Daher muss die gesamte Zeile (mit # als erstes Zeichen der
### Zeile) auszukommentieren oder entfernt werden. Nur keinen Ablageort einzutragen ist unasreichend.
# ca_cert=""
phase2="auth=PAP"
}
</pre></code>
Getestet ist die Nutzung an unserer [[HTW Dresden]] und an der [[TU Dresden]].


==== Video ====
==== Video ====


My main concern was video. X60 has Intel Graphics Media Accelerator 950. Luckily, latest driver combine with FreeBSD 8.1 gives no problems. Get the driver from /usr/ports/x11-drivers/xf86-video-intel/.
My main concern was video. X60 has Intel Graphics Media Accelerator 950. Luckily, latest driver combine with FreeBSD 8.1 gives no problems. Get the driver from /usr/ports/x11-drivers/xf86-video-intel/.


==== Xorg ====
==== Xorg ====
Zeile 180: Zeile 130:


===== Keyboard =====
===== Keyboard =====
Set the Keyboardlayout to German in Xorg
Set the Keyboardlayout to German
 
'''Worked in FreeBSD 9.0'''
Create in /usr/local/etc/hal/fdi/policy a file named x11-input.fdi and write in


  <?xml version="1.0" encoding="ISO-8859-1"?>
  <?xml version="1.0" encoding="ISO-8859-1"?>
Zeile 194: Zeile 141:
  </device>
  </device>
  </deviceinfo>
  </deviceinfo>
Set the Keyboardlayout to German on FreeBSD Console
# vim /etc/rc.conf
font8x16="iso-8x16"
font8x14="iso-8x14"
font8x8="iso-8x8"
keymap="german.iso"


==== Trackpad scrolling ====
==== Trackpad scrolling ====
Zeile 235: Zeile 173:
  Files
  Files
  FontPath “/usr/local/lib/X11/fonts/webfonts/
  FontPath “/usr/local/lib/X11/fonts/webfonts/


==== Flash ====
==== Flash ====
'''worked on 9.0'''


As you know, native flash support is not available in FreeBSD still. You may speed things up by clicking on the links in the top right corner of the website to sign the petition and vote up the bug report on Adobe website.
As you know, native flash support is not available in FreeBSD still. You may speed things up by clicking on the links in the top right corner of the website to sign the petition and vote up the bug report on Adobe website.


We can get flash working with Linux emulation. My setup was straightforward.
We can get flash working with Linux emulation. My setup was straightforward. I use Opera so my setup was in this order:


Edit /etc/rc.conf:
Edit /etc/rc.conf:
Zeile 248: Zeile 186:


Install:
Install:
* general:


  /usr/ports/emulators/linux_base-f10/
  /usr/ports/emulators/linux_base-f10/
/usr/ports/www/linux-f10-flashplugin10/ or linux-f10-flashplugin11/
* Ports for Opera:
  /usr/ports/www/opera/
  /usr/ports/www/opera/
  /usr/ports/www/opera-linuxplugins/
  /usr/ports/www/opera-linuxplugins/
/usr/ports/www/linux-f10-flashplugin10/


I didn’t have to add any path in Opera or setup any symlinks to get flash working.
I didn’t have to add any path in Opera or setup any symlinks to get flash working.
* Ports for Firefox:
www/nspluginwrapper
** continue:
exec
nspluginwrapper -v -a -i
edit fstab
linproc /compat/linux/proc linprocfs rw  0  0
'''I'm not need it:''' Putting a link of libflashplayer.so to /usr/local/lib/firefox/plugins and ~/.mozilla/plugins directories and running nspluginwrapper again.


==== Card Reader ====
==== Card Reader ====
Zeile 282: Zeile 199:


  mmc_load=”YES”
  mmc_load=”YES”
  mmcsd_load=”YES”   #für SD
  mmcsd_load=”YES”
sdhci_load="YES"  #für SDHC Cards


If you wish to build it directly into a custom kernel, add these lines to the kernel configuration (worked with 9.0)
If you wish to build it directly into a custom kernel, add these lines to the kernel configuration (worked with 9.0)
Zeile 289: Zeile 205:
  device        mmc
  device        mmc
  device        mmcsd
  device        mmcsd
device        sdhci


==== Bluetooth disable ====
==== Bluetooth disable ====
Zeile 295: Zeile 210:
I like to hardware disable bluetooth so I get longer battery life. Once IBM acpi is loaded, I can Fn+F5. It will switch on and off the bluetooth without touching wireless (I don’t know if it’s a bug or not, but this works better for me rather than shuffling through wifi as well).
I like to hardware disable bluetooth so I get longer battery life. Once IBM acpi is loaded, I can Fn+F5. It will switch on and off the bluetooth without touching wireless (I don’t know if it’s a bug or not, but this works better for me rather than shuffling through wifi as well).


==== Communication ====
=== Weblinks ===
 
===== mcabber =====
 
* patch mcabber for using libotr v4
** fetch files from OpenBSD git repository the patches
 
https://github.com/toddfries/OpenBSD-ports-patches/tree/2dc03c301749b462889226d4b738cd07773623ee/net/mcabber
 
* rewrite filenames
 
<code>
patch-configure_ac  -->  patch-configure.ac
patch-mcabber_otr_c  -->  patch-mcabber_otr.c
patch-mcabber_otr_h  -->  patch-mcabber_otr.h
</code>
 
and move them to ${PORTDIR}/net-im/mcabber/files/
 
additionaly I had modify my "Makefile"
 
; Makefile
use only libotr v4
 
<code>
LIB_DEPENDS+= otr.4:${PORTSDIR}/security/libotr3  -->  LIB_DEPENDS+= otr:${PORTSDIR}/security/libotr
</code>
 
== Dienste ==
 
===== Verwaltung von Diensten mit sysrc =====
: "der Standard"
 
[[man:sysrc]]
 
* https://www.linuxsecrets.com/home/2930-freebsd-configuration-tool-sysrc
 
== WLAN ==
 
=== Hardware für WLAN ===
 
Bei ''pciconf'' mal nach ''wifi'' suchen.
: <code>pciconf -lv | grep -i wifi</code>
 
=== einzelne Treiber für WLAN ===
 
==== Treiber ''[[freebsd-man:urtwn|urtwn]]'' ====
 
etwa beim Thinkpad&nbsp;L530
: <code>pciconf -lv | grep -i wifi</code>
<pre>
    device    = 'RTL8188CE 802.11b/g/n WiFi Adapter'
</pre>
: <code>$EDITOR /boot/loader.conf</code>
<pre></pre>
<pre>
if_urtwn_load="YES"
legal.realtek.license_ack=1
</pre>
<pre></pre>
: <code>reboot</code>
 
== nette Gefälligkeiten ==
 
==== automatische Vervollständigung einschalten ====
 
===== automatische Vervollständigung einschalten bei zsh =====
 
; Eintragungen bei der Datei für die persönlichen Einstellungen für zsh<sup>[https://wiki.archlinux.org/index.php/Zsh#Command_completion]</sup>
: <code>$EDITOR ~/.zshrc</code>
<pre></pre>
<pre>
autoload -U compinit
compinit
</pre>
<pre></pre>
 
===== automatische Vervollständigung einschalten bei bash =====
 
; Eintragungen bei der Datei für die persönlichen Einstellungen für bash
: <code>$EDITOR ~/.bash</code>
<pre></pre>
<pre>
if ! shopt -oq posix; then
  if [ -f /usr/share/bash-completion/bash_completion ]; then
    . /usr/share/bash-completion/bash_completion
  elif [ -f /etc/bash_completion ]; then
    . /etc/bash_completion
  fi
fi
</pre>
<pre></pre>
 
== wenn mal wer umzieht ==
 
=== Sachen packen ===
 
… Ich packe meinen Koffer und nehme mit …
 
Dinge, die Mensch wohl gern mitnehmen möchten:
{|
|-
! Datei bzw. Ordner
! üblicher Ort
! Zweck
|-
| wpa_supplicant.conf
| /etc/wpa_supplicant.conf
| Verwaltung von Zugängen für Netzwerkverbindungen (insbesondere auch für Passwörter für drahtlose Netzwerke)
|-
|}
 
=== Umzugsservice ===
 
==== Umziehen von einem Pool von ZFS ====
Dank ZFS kann Umziehen richtig einfach sein.
 
Es kann ein jeder Pool in einem Dataset eines externen Pools zwischengespeichert werden.


== Weblinks ==
* [http://www.freebsd.org/doc/de_DE.ISO8859-1/books/handbook/kernelconfig-building.html Kernel building and install]
* [http://www.freebsd.org/doc/de_DE.ISO8859-1/books/handbook/kernelconfig-building.html Kernel building and install]
* [https://www.freebsdfoundation.org/freebsd/how-to-guides/installing-a-desktop-environment-on-freebsd/ FreeBSD Foundation: How-To Guides: Installing a Desktop Environment on FreeBSD]
* [https://cooltrainer.org/a-freebsd-desktop-howto/ A FreeBSD Desktop How-to]


[[Kategorie:BSD]]
[[Kategorie:Rechentechnik]]
[[Kategorie:Hardware]]
[[Kategorie:Hardware]]
[[Kategorie:Software]]

Bitte beachte, dass alle Beiträge zu Wiki StuRa HTW Dresden von anderen Mitwirkenden bearbeitet, geändert oder gelöscht werden können. Reiche hier keine Texte ein, falls du nicht willst, dass diese ohne Einschränkung geändert werden können.

Du bestätigst hiermit auch, dass du diese Texte selbst geschrieben hast oder diese von einer gemeinfreien Quelle kopiert hast (weitere Einzelheiten unter StuRa HTW Dresden:Urheberrechte). ÜBERTRAGE OHNE GENEHMIGUNG KEINE URHEBERRECHTLICH GESCHÜTZTEN INHALTE!

Bitte beantworte die folgende Frage, um diese Seite speichern zu können (weitere Informationen):

Abbrechen Bearbeitungshilfe (wird in einem neuen Fenster geöffnet)