StuRa Diskussion:Server/srs14: Unterschied zwischen den Versionen

Aus Wiki StuRa HTW Dresden
Wechseln zu: Navigation, Suche
(Problem der nicht passenden Referenz für die Version vom Kernel für die Pakete bei pkg)
(Neuer Abschnitt Erweiterung des vertrauenswürdigen "eigenen" Netzwerks auf die Bereich an Adresse für IPv4 auf die gesamte Hochschule)
 
(15 dazwischenliegende Versionen von 2 Benutzern werden nicht angezeigt)
Zeile 19: Zeile 19:
 
== Problem der nicht passenden Referenz für die Version vom Kernel für die Pakete bei <code>pkg</code> ==
 
== Problem der nicht passenden Referenz für die Version vom Kernel für die Pakete bei <code>pkg</code> ==
  
; done!
+
; <s>done!</s>
 +
 
 +
 
 +
<!--
 +
sudo pkg update -f
 +
Updating FreeBSD repository catalogue...
 +
[srs14] Fetching meta.txz: 100%    944 B  0.9kB/s    00:01   
 +
[srs14] Fetching packagesite.txz: 100%    6 MiB  6.4MB/s    00:01   
 +
Processing entries:  0%
 +
Newer FreeBSD version for package mujs:
 +
To ignore this error set IGNORE_OSVERSION=yes
 +
- package: 1101001
 +
- running kernel: 1100122
 +
Allow missmatch now?[Y/n]: y
 +
Processing entries: 100%
 +
FreeBSD repository update completed. 31153 packages processed.
 +
All repositories are up to date.
 +
 
 +
----
 +
 
 +
sudo pkg update -f
 +
Updating FreeBSD repository catalogue...
 +
[srs14] Fetching meta.txz: 100%    944 B  0.9kB/s    00:01   
 +
[srs14] Fetching packagesite.txz: 100%    6 MiB  3.2MB/s    00:02   
 +
Processing entries:  0%
 +
Newer FreeBSD version for package mujs:
 +
To ignore this error set IGNORE_OSVERSION=yes
 +
- package: 1101001
 +
- running kernel: 1100122
 +
Allow missmatch now?[Y/n]: n
 +
pkg: repository FreeBSD contains packages for wrong OS version: FreeBSD:11:amd64
 +
Processing entries: 100%
 +
Unable to update repository FreeBSD
 +
Error updating repositories!
 +
 
 +
-->
 +
<s>
 +
Ermitteln der Version vom aktuell verwendeten Kernel
 +
: <code>uname -ku</code>
 +
<pre>
 +
1234567
 +
</pre>
 +
Übliche Benutyung von <code>pkg update</code>, jedoch mit Angabe einer bestimmten Version vom (aktuell verwendeten) Kernel
 +
: <code>pkg -o OSVERSION=1234567 update</code>
 +
: <code>upgrade -y</code>
 +
</s>
 +
 
 +
== Vorbereitung zu CAPTCHA für Mailman ==
 +
 
 +
=== [[wikipedia:de:ReCAPTCHA|recaptcha]] ===
 +
; No!
 +
<s>
 +
 
 +
Achtung! [https://www.google.com/recaptcha/ Es handelt sich um Dienst, der von google angeboten wird.]
 +
 
 +
: <code>pkg install -y py27-recaptcha</code>
 +
: <code>pkg install -y py27-pycrypto</code>
 +
</s>
 +
 
 +
* es braucht (wohl) einen key, der mit einem account bei google erstellt werden muss.
 +
* Aktuelles Paket ist nur für die Version 1. [https://developers.google.com/recaptcha/docs/changelog Die Version 1 steht (seitens google seit Ablauf März 2018 nicht mehr zur Verfügung.]
 +
 
 +
== Aktualisierung der installierten Paket 2018-06-04 ==
 +
 
 +
* jail gestoppt
 +
* snapshot datasets (alle 4 relevanten)
 +
* jail gestartet
 +
: <code>sudo pkg update && pkg upgrade -y</code>
 +
<pre></pre><!--
 +
No packages matched for pattern 'py27-recaptcha'
 +
 
 +
Checking integrity... done (0 conflicting)
 +
1 packages requested for removal: 0 locked, 1 missing
 +
[vater@srs14 /usr/home/vater]$ pkg update && pkg upgrade -y
 +
pkg: Insufficient privileges to update the repository catalogue.
 +
[vater@srs14 /usr/home/vater]$ sudo pkg update && sudo pkg upgrade -y
 +
Updating FreeBSD repository catalogue...
 +
FreeBSD repository is up to date.
 +
All repositories are up to date.
 +
Updating FreeBSD repository catalogue...
 +
FreeBSD repository is up to date.
 +
All repositories are up to date.
 +
Checking for upgrades (36 candidates): 100%
 +
Processing candidates (36 candidates): 100%
 +
The following 30 package(s) will be affected (of 0 checked):
 +
 
 +
Installed packages to be UPGRADED:
 +
        wget: 1.19.4 -> 1.19.5
 +
        unibilium: 1.2.1 -> 2.0.0
 +
        subversion: 1.9.7_2 -> 1.9.7_4
 +
        sqlite3: 3.21.0_1 -> 3.22.0_2
 +
        serf: 1.3.9_1 -> 1.3.9_3
 +
        python27: 2.7.14_1 -> 2.7.15
 +
        py27-setuptools: 38.2.5 -> 39.0.1
 +
        perl5: 5.24.3 -> 5.26.2
 +
        neovim: 0.2.2 -> 0.2.2_1
 +
        libuv: 1.19.1 -> 1.19.2
 +
        libunistring: 0.9.8 -> 0.9.9
 +
        libtermkey: 0.20 -> 0.20_1
 +
        libnghttp2: 1.30.0 -> 1.31.1
 +
        icu: 60.2_1,1 -> 61.1,1
 +
        help2man: 1.47.5 -> 1.47.6
 +
        git: 2.16.1 -> 2.16.3
 +
        curl: 7.58.0_1 -> 7.60.0
 +
        ca_root_nss: 3.35 -> 3.37.1
 +
        bash: 4.4.12_3 -> 4.4.19
 +
        apr: 1.6.3.1.6.1 -> 1.6.3.1.6.1_1
 +
        apache24: 2.4.29 -> 2.4.33
 +
 
 +
Installed packages to be REINSTALLED:
 +
        texinfo-6.5,1 (direct dependency changed: perl5)
 +
        p5-Locale-gettext-1.07 (direct dependency changed: perl5)
 +
        p5-GSSAPI-0.28_1 (direct dependency changed: perl5)
 +
        p5-Error-0.17025 (direct dependency changed: perl5)
 +
        p5-Digest-HMAC-1.03_1 (direct dependency changed: perl5)
 +
        p5-Authen-SASL-2.16_1 (direct dependency changed: perl5)
 +
        libvterm-git20161218 (direct dependency changed: perl5)
 +
        automake-1.15.1 (direct dependency changed: perl5)
 +
        autoconf-2.69_1 (direct dependency changed: perl5)
 +
 
 +
Number of packages to be upgraded: 21
 +
Number of packages to be reinstalled: 9
 +
 
 +
The process will require 3 MiB more space.
 +
59 MiB to be downloaded.
 +
[srs14] [1/30] Fetching wget-1.19.5.txz: 100%  620 KiB 635.4kB/s    00:01   
 +
[srs14] [2/30] Fetching unibilium-2.0.0.txz: 100%  112 KiB 114.5kB/s    00:01   
 +
[srs14] [3/30] Fetching texinfo-6.5,1.txz: 100%    1 MiB  1.3MB/s    00:01   
 +
[srs14] [4/30] Fetching subversion-1.9.7_4.txz: 100%    3 MiB 729.9kB/s    00:04   
 +
[srs14] [5/30] Fetching sqlite3-3.22.0_2.txz: 100%    1 MiB  1.2MB/s    00:01   
 +
[srs14] [6/30] Fetching serf-1.3.9_3.txz: 100%  78 KiB  80.4kB/s    00:01   
 +
[srs14] [7/30] Fetching python27-2.7.15.txz: 100%  11 MiB  1.8MB/s    00:06   
 +
[srs14] [8/30] Fetching py27-setuptools-39.0.1.txz: 100%  464 KiB 475.5kB/s    00:01   
 +
[srs14] [9/30] Fetching perl5-5.26.2.txz: 100%  14 MiB  4.8MB/s    00:03   
 +
[srs14] [10/30] Fetching p5-Locale-gettext-1.07.txz: 100%  16 KiB  16.9kB/s    00:01   
 +
[srs14] [11/30] Fetching p5-GSSAPI-0.28_1.txz: 100%  41 KiB  41.9kB/s    00:01   
 +
[srs14] [12/30] Fetching p5-Error-0.17025.txz: 100%  19 KiB  19.3kB/s    00:01   
 +
[srs14] [13/30] Fetching p5-Digest-HMAC-1.03_1.txz: 100%  10 KiB  10.1kB/s    00:01   
 +
[srs14] [14/30] Fetching p5-Authen-SASL-2.16_1.txz: 100%  40 KiB  41.3kB/s    00:01   
 +
[srs14] [15/30] Fetching neovim-0.2.2_1.txz: 100%    4 MiB  4.1MB/s    00:01   
 +
[srs14] [16/30] Fetching libvterm-git20161218.txz: 100%  45 KiB  46.4kB/s    00:01   
 +
[srs14] [17/30] Fetching libuv-1.19.2.txz: 100%  95 KiB  96.8kB/s    00:01   
 +
[srs14] [18/30] Fetching libunistring-0.9.9.txz: 100%  522 KiB 534.4kB/s    00:01   
 +
[srs14] [19/30] Fetching libtermkey-0.20_1.txz: 100%  51 KiB  51.8kB/s    00:01   
 +
[srs14] [20/30] Fetching libnghttp2-1.31.1.txz: 100%  108 KiB 110.4kB/s    00:01   
 +
[srs14] [21/30] Fetching icu-61.1,1.txz: 100%    9 MiB  1.4MB/s    00:07   
 +
[srs14] [22/30] Fetching help2man-1.47.6.txz: 100%  141 KiB 144.0kB/s    00:01   
 +
[srs14] [23/30] Fetching git-2.16.3.txz: 100%    4 MiB  2.3MB/s    00:02   
 +
[srs14] [24/30] Fetching curl-7.60.0.txz: 100%    1 MiB  1.2MB/s    00:01   
 +
[srs14] [25/30] Fetching ca_root_nss-3.37.1.txz: 100%  287 KiB 294.1kB/s    00:01   
 +
[srs14] [26/30] Fetching bash-4.4.19.txz: 100%    1 MiB  1.5MB/s    00:01   
 +
[srs14] [27/30] Fetching automake-1.15.1.txz: 100%  445 KiB 455.3kB/s    00:01   
 +
[srs14] [28/30] Fetching autoconf-2.69_1.txz: 100%  542 KiB 555.4kB/s    00:01   
 +
[srs14] [29/30] Fetching apr-1.6.3.1.6.1_1.txz: 100%  453 KiB 464.1kB/s    00:01   
 +
[srs14] [30/30] Fetching apache24-2.4.33.txz: 100%    5 MiB  1.3MB/s    00:04   
 +
Checking integrity... done (0 conflicting)
 +
[srs14] [1/30] Upgrading perl5 from 5.24.3 to 5.26.2...
 +
[srs14] [1/30] Extracting perl5-5.26.2: 100%
 +
[srs14] [2/30] Upgrading unibilium from 1.2.1 to 2.0.0...
 +
[srs14] [2/30] Extracting unibilium-2.0.0: 100%
 +
[srs14] [3/30] Reinstalling p5-GSSAPI-0.28_1...
 +
[srs14] [3/30] Extracting p5-GSSAPI-0.28_1: 100%
 +
[srs14] [4/30] Reinstalling p5-Digest-HMAC-1.03_1...
 +
[srs14] [4/30] Extracting p5-Digest-HMAC-1.03_1: 100%
 +
[srs14] [5/30] Upgrading libunistring from 0.9.8 to 0.9.9...
 +
[srs14] [5/30] Extracting libunistring-0.9.9: 100%
 +
[srs14] [6/30] Upgrading libnghttp2 from 1.30.0 to 1.31.1...
 +
[srs14] [6/30] Extracting libnghttp2-1.31.1: 100%
 +
[srs14] [7/30] Upgrading ca_root_nss from 3.35 to 3.37.1...
 +
[srs14] [7/30] Extracting ca_root_nss-3.37.1: 100%
 +
[srs14] [8/30] Upgrading apr from 1.6.3.1.6.1 to 1.6.3.1.6.1_1...
 +
[srs14] [8/30] Extracting apr-1.6.3.1.6.1_1: 100%
 +
[srs14] [9/30] Upgrading sqlite3 from 3.21.0_1 to 3.22.0_2...
 +
[srs14] [9/30] Extracting sqlite3-3.22.0_2: 100%
 +
[srs14] [10/30] Upgrading serf from 1.3.9_1 to 1.3.9_3...
 +
[srs14] [10/30] Extracting serf-1.3.9_3: 100%
 +
[srs14] [11/30] Upgrading python27 from 2.7.14_1 to 2.7.15...
 +
[srs14] [11/30] Extracting python27-2.7.15: 100%
 +
[srs14] [12/30] Reinstalling p5-Locale-gettext-1.07...
 +
[srs14] [12/30] Extracting p5-Locale-gettext-1.07: 100%
 +
[srs14] [13/30] Reinstalling p5-Error-0.17025...
 +
[srs14] [13/30] Extracting p5-Error-0.17025: 100%
 +
[srs14] [14/30] Reinstalling p5-Authen-SASL-2.16_1...
 +
[srs14] [14/30] Extracting p5-Authen-SASL-2.16_1: 100%
 +
[srs14] [15/30] Reinstalling libvterm-git20161218...
 +
[srs14] [15/30] Extracting libvterm-git20161218: 100%
 +
[srs14] [16/30] Upgrading libuv from 1.19.1 to 1.19.2...
 +
[srs14] [16/30] Extracting libuv-1.19.2: 100%
 +
[srs14] [17/30] Upgrading libtermkey from 0.20 to 0.20_1...
 +
[srs14] [17/30] Extracting libtermkey-0.20_1: 100%
 +
[srs14] [18/30] Upgrading curl from 7.58.0_1 to 7.60.0...
 +
[srs14] [18/30] Extracting curl-7.60.0: 100%
 +
[srs14] [19/30] Reinstalling autoconf-2.69_1...
 +
[srs14] [19/30] Extracting autoconf-2.69_1: 100%
 +
[srs14] [20/30] Upgrading wget from 1.19.4 to 1.19.5...
 +
[srs14] [20/30] Extracting wget-1.19.5: 100%
 +
[srs14] [21/30] Reinstalling texinfo-6.5,1...
 +
[srs14] [21/30] Extracting texinfo-6.5,1: 100%
 +
[srs14] [22/30] Upgrading subversion from 1.9.7_2 to 1.9.7_4...
 +
[srs14] [22/30] Extracting subversion-1.9.7_4: 100%
 +
[srs14] [23/30] Upgrading py27-setuptools from 38.2.5 to 39.0.1...
 +
[srs14] [23/30] Extracting py27-setuptools-39.0.1: 100%
 +
[srs14] [24/30] Upgrading neovim from 0.2.2 to 0.2.2_1...
 +
[srs14] [24/30] Extracting neovim-0.2.2_1: 100%
 +
[srs14] [25/30] Upgrading icu from 60.2_1,1 to 61.1,1...
 +
[srs14] [25/30] Extracting icu-61.1,1: 100%
 +
[srs14] [26/30] Upgrading help2man from 1.47.5 to 1.47.6...
 +
[srs14] [26/30] Extracting help2man-1.47.6: 100%
 +
[srs14] [27/30] Upgrading git from 2.16.1 to 2.16.3...
 +
===> Creating groups.
 +
Using existing group 'git_daemon'.
 +
===> Creating users
 +
Using existing user 'git_daemon'.
 +
[srs14] [27/30] Extracting git-2.16.3: 100%
 +
[srs14] [28/30] Upgrading bash from 4.4.12_3 to 4.4.19...
 +
[srs14] [28/30] Extracting bash-4.4.19: 100%
 +
[srs14] [29/30] Reinstalling automake-1.15.1...
 +
[srs14] [29/30] Extracting automake-1.15.1: 100%
 +
[srs14] [30/30] Upgrading apache24 from 2.4.29 to 2.4.33...
 +
===> Creating groups.
 +
Using existing group 'www'.
 +
===> Creating users
 +
Using existing user 'www'.
 +
[srs14] [30/30] Extracting apache24-2.4.33: 100%
 +
You may need to manually remove /usr/local/etc/apache24/extra/httpd-vhosts.conf if it is no longer needed.
 +
You may need to manually remove /usr/local/etc/apache24/httpd.conf if it is no longer needed.
 +
Message from perl5-5.26.2:
 +
 
 +
The /usr/bin/perl symlink has been removed starting with Perl 5.20.
 +
For shebangs, you should either use:
 +
 
 +
#!/usr/local/bin/perl
 +
 
 +
or
 +
 
 +
#!/usr/bin/env perl
 +
 
 +
The first one will only work if you have a /usr/local/bin/perl,
 +
the second will work as long as perl is in PATH.
 +
Message from ca_root_nss-3.37.1:
 +
 
 +
********************************* WARNING *********************************
 +
 
 +
FreeBSD does not, and can not warrant that the certification authorities
 +
whose certificates are included in this package have in any way been
 +
audited for trustworthiness or RFC 3647 compliance.
 +
 
 +
Assessment and verification of trust is the complete responsibility of the
 +
system administrator.
 +
 
 +
*********************************** NOTE **********************************
 +
 
 +
This package installs symlinks to support root certificates discovery by
 +
default for software that uses OpenSSL.
 +
 
 +
This enables SSL Certificate Verification by client software without manual
 +
intervention.
 +
 
 +
If you prefer to do this manually, replace the following symlinks with
 +
either an empty file or your site-local certificate bundle.
 +
 
 +
  * /etc/ssl/cert.pem
 +
  * /usr/local/etc/ssl/cert.pem
 +
  * /usr/local/openssl/cert.pem
 +
 
 +
***************************************************************************
 +
Message from apr-1.6.3.1.6.1_1:
 +
 
 +
/!\ ================================================================== /!\
 +
 
 +
The Apache Portable Runtime project removed support for FreeTDS with
 +
version 1.6. Users requiring MS-SQL connectivity must migrate
 +
configurations to use the added ODBC driver and FreeTDS' ODBC features.
 +
 
 +
/!\ ================================================================== /!\
 +
Message from python27-2.7.15:
 +
 
 +
===========================================================================
 +
 
 +
Note that some standard Python modules are provided as separate ports
 +
as they require additional dependencies. They are available as:
 +
 
 +
bsddb          databases/py-bsddb
 +
gdbm            databases/py-gdbm
 +
sqlite3        databases/py-sqlite3
 +
tkinter        x11-toolkits/py-tkinter
 +
 
 +
===========================================================================
 +
Message from git-2.16.3:
 +
 
 +
------------------------------------------------------------------------
 +
*************************** GITWEB *************************************
 +
If you installed the GITWEB option please follow these instructions:
 +
 
 +
In the directory /usr/local/share/examples/git/gitweb you can find all files to
 +
make gitweb work as a public repository on the web.
 +
 
 +
All you have to do to make gitweb work is:
 +
1) Copy the files /usr/local/share/examples/git/gitweb/* to a directory on
 +
  your web server (e.g. Apache2) in which you are able to execute
 +
  CGI-scripts.
 +
2) In gitweb.cgi, adjust the variable $projectroot to point to
 +
  your git repository (that is where you have your *.git project
 +
  directories).
 +
*************************** GITWEB *************************************
 +
 
 +
*************************** CONTRIB ************************************
 +
If you installed the CONTRIB option please note that the scripts are
 +
installed in /usr/local/share/git-core/contrib. Some of them require
 +
other ports to be installed (perl, python, etc), which you may need to
 +
install manually.
 +
*************************** CONTRIB ************************************
 +
------------------------------------------------------------------------
 +
Message from apache24-2.4.33:
 +
 
 +
To run apache www server from startup, add apache24_enable="yes"
 +
in your /etc/rc.conf. Extra options can be found in startup script.
 +
 
 +
Your hostname must be resolvable using at least 1 mechanism in
 +
/etc/nsswitch.conf typically DNS or /etc/hosts or apache might
 +
have issues starting depending on the modules you are using.
 +
 
 +
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
 +
 
 +
- apache24 default build changed from static MPM to modular MPM
 +
- more modules are now enabled per default in the port
 +
- icons and error pages moved from WWWDIR to DATADIR
 +
 
 +
  If build with modular MPM and no MPM is activated in
 +
  httpd.conf, then mpm_prefork will be activated as default
 +
  MPM in etc/apache24/modules.d to keep compatibility with
 +
  existing php/perl/python modules!
 +
 
 +
Please compare the existing httpd.conf with httpd.conf.sample
 +
and merge missing modules/instructions into httpd.conf!
 +
 
 +
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
 +
!-->
 +
* jail neugestartet
 +
 
 +
 
 +
<code>pkg update -f</code>
 +
<pre></pre>
 +
<!--
 +
Updating FreeBSD repository catalogue...
 +
pkg: Repository FreeBSD has a wrong packagesite, need to re-create database
 +
[srs14] Fetching meta.txz: 100%    944 B  0.9kB/s    00:01   
 +
[srs14] Fetching packagesite.txz: 100%    6 MiB  6.6MB/s    00:01   
 +
Processing entries:  0%
 +
Newer FreeBSD version for package kipi-plugin-smug:
 +
To ignore this error set IGNORE_OSVERSION=yes
 +
- package: 1101001
 +
- running kernel: 1100122
 +
Allow missmatch now?[Y/n]:
 +
Processing entries: 100%
 +
FreeBSD repository update completed. 31988 packages processed.
 +
All repositories are up to date.
 +
!-->
 +
 
 +
: <code>sudo pkg upgrade -y</code>
 +
<pre></pre>
 +
<!--
 +
Updating FreeBSD repository catalogue...
 +
FreeBSD repository is up to date.
 +
All repositories are up to date.
 +
New version of pkg detected; it needs to be installed first.
 +
The following 1 package(s) will be affected (of 0 checked):
 +
 
 +
Installed packages to be UPGRADED:
 +
        pkg: 1.10.5 -> 1.10.5_1
 +
 
 +
Number of packages to be upgraded: 1
 +
 
 +
3 MiB to be downloaded.
 +
[srs14] [1/1] Fetching pkg-1.10.5_1.txz: 100%    3 MiB  3.0MB/s    00:01   
 +
Checking integrity... done (0 conflicting)
 +
[srs14] [1/1] Upgrading pkg from 1.10.5 to 1.10.5_1...
 +
[srs14] [1/1] Extracting pkg-1.10.5_1: 100%
 +
You may need to manually remove /usr/local/etc/pkg.conf if it is no longer needed.
 +
Updating FreeBSD repository catalogue...
 +
FreeBSD repository is up to date.
 +
All repositories are up to date.
 +
Checking for upgrades (22 candidates): 100%
 +
Processing candidates (22 candidates): 100%
 +
The following 21 package(s) will be affected (of 0 checked):
 +
 
 +
New packages to be INSTALLED:
 +
        utf8proc: 2.1.0
 +
        liblz4: 1.8.2,1
 +
        p5-CGI: 4.38
 +
        p5-HTML-Parser: 3.72
 +
        p5-HTML-Tagset: 3.20_1
 +
 
 +
Installed packages to be UPGRADED:
 +
        tmux: 2.6_1 -> 2.7
 +
        sudo: 1.8.22 -> 1.8.23_2
 +
        subversion: 1.9.7_4 -> 1.10.0
 +
        sqlite3: 3.22.0_2 -> 3.23.1
 +
        py27-setuptools: 39.0.1 -> 39.2.0
 +
        pcre: 8.40_1 -> 8.42
 +
        p5-Error: 0.17025 -> 0.17026
 +
        neovim: 0.2.2_1 -> 0.2.2_2
 +
        msgpack: 1.4.2_3 -> 3.0.1
 +
        libuv: 1.19.2 -> 1.20.3
 +
        libnghttp2: 1.31.1 -> 1.32.0
 +
        libidn2: 2.0.4 -> 2.0.5
 +
        git: 2.16.3 -> 2.17.1
 +
        bash: 4.4.19 -> 4.4.23
 +
        apache24: 2.4.33 -> 2.4.33_1
 +
 
 +
Installed packages to be REINSTALLED:
 +
        curl-7.60.0 (options changed)
 +
 
 +
Number of packages to be installed: 5
 +
Number of packages to be upgraded: 15
 +
Number of packages to be reinstalled: 1
 +
 
 +
The process will require 5 MiB more space.
 +
24 MiB to be downloaded.
 +
[srs14] [1/21] Fetching tmux-2.7.txz: 100%  254 KiB 259.9kB/s    00:01   
 +
[srs14] [2/21] Fetching sudo-1.8.23_2.txz: 100%  669 KiB 685.5kB/s    00:01   
 +
[srs14] [3/21] Fetching subversion-1.10.0.txz: 100%    3 MiB  3.2MB/s    00:01   
 +
[srs14] [4/21] Fetching sqlite3-3.23.1.txz: 100%    1 MiB  1.2MB/s    00:01   
 +
[srs14] [5/21] Fetching py27-setuptools-39.2.0.txz: 100%  465 KiB 476.4kB/s    00:01   
 +
[srs14] [6/21] Fetching pcre-8.42.txz: 100%    1 MiB  1.2MB/s    00:01   
 +
[srs14] [7/21] Fetching p5-Error-0.17026.txz: 100%  22 KiB  23.0kB/s    00:01   
 +
[srs14] [8/21] Fetching neovim-0.2.2_2.txz: 100%    4 MiB  2.1MB/s    00:02   
 +
[srs14] [9/21] Fetching msgpack-3.0.1.txz: 100%  228 KiB 233.8kB/s    00:01   
 +
[srs14] [10/21] Fetching libuv-1.20.3.txz: 100%  94 KiB  96.7kB/s    00:01   
 +
[srs14] [11/21] Fetching libnghttp2-1.32.0.txz: 100%  109 KiB 111.6kB/s    00:01   
 +
[srs14] [12/21] Fetching libidn2-2.0.5.txz: 100%  103 KiB 105.9kB/s    00:01   
 +
[srs14] [13/21] Fetching git-2.17.1.txz: 100%    5 MiB  4.7MB/s    00:01   
 +
[srs14] [14/21] Fetching curl-7.60.0.txz: 100%    1 MiB  1.2MB/s    00:01   
 +
[srs14] [15/21] Fetching bash-4.4.23.txz: 100%    1 MiB  1.5MB/s    00:01   
 +
[srs14] [16/21] Fetching apache24-2.4.33_1.txz: 100%    5 MiB  2.6MB/s    00:02   
 +
[srs14] [17/21] Fetching utf8proc-2.1.0.txz: 100%  57 KiB  58.3kB/s    00:01   
 +
[srs14] [18/21] Fetching liblz4-1.8.2,1.txz: 100%  114 KiB 116.9kB/s    00:01   
 +
[srs14] [19/21] Fetching p5-CGI-4.38.txz: 100%  158 KiB 161.8kB/s    00:01   
 +
[srs14] [20/21] Fetching p5-HTML-Parser-3.72.txz: 100%  80 KiB  81.5kB/s    00:01   
 +
[srs14] [21/21] Fetching p5-HTML-Tagset-3.20_1.txz: 100%  12 KiB  12.0kB/s    00:01   
 +
Checking integrity... done (0 conflicting)
 +
[srs14] [1/21] Installing p5-HTML-Tagset-3.20_1...
 +
[srs14] [1/21] Extracting p5-HTML-Tagset-3.20_1: 100%
 +
[srs14] [2/21] Upgrading libnghttp2 from 1.31.1 to 1.32.0...
 +
[srs14] [2/21] Extracting libnghttp2-1.32.0: 100%
 +
[srs14] [3/21] Installing p5-HTML-Parser-3.72...
 +
[srs14] [3/21] Extracting p5-HTML-Parser-3.72: 100%
 +
[srs14] [4/21] Upgrading sqlite3 from 3.22.0_2 to 3.23.1...
 +
[srs14] [4/21] Extracting sqlite3-3.23.1: 100%
 +
[srs14] [5/21] Upgrading pcre from 8.40_1 to 8.42...
 +
[srs14] [5/21] Extracting pcre-8.42: 100%
 +
[srs14] [6/21] Upgrading p5-Error from 0.17025 to 0.17026...
 +
[srs14] [6/21] Extracting p5-Error-0.17026: 100%
 +
[srs14] [7/21] Upgrading msgpack from 1.4.2_3 to 3.0.1...
 +
[srs14] [7/21] Extracting msgpack-3.0.1: 100%
 +
[srs14] [8/21] Upgrading libuv from 1.19.2 to 1.20.3...
 +
[srs14] [8/21] Extracting libuv-1.20.3: 100%
 +
[srs14] [9/21] Reinstalling curl-7.60.0...
 +
[srs14] [9/21] Extracting curl-7.60.0: 100%
 +
[srs14] [10/21] Installing utf8proc-2.1.0...
 +
[srs14] [10/21] Extracting utf8proc-2.1.0: 100%
 +
[srs14] [11/21] Installing liblz4-1.8.2,1...
 +
[srs14] [11/21] Extracting liblz4-1.8.2,1: 100%
 +
[srs14] [12/21] Installing p5-CGI-4.38...
 +
[srs14] [12/21] Extracting p5-CGI-4.38: 100%
 +
[srs14] [13/21] Upgrading tmux from 2.6_1 to 2.7...
 +
[srs14] [13/21] Extracting tmux-2.7: 100%
 +
[srs14] [14/21] Upgrading sudo from 1.8.22 to 1.8.23_2...
 +
[srs14] [14/21] Extracting sudo-1.8.23_2: 100%
 +
You may need to manually remove /usr/local/etc/sudoers if it is no longer needed.
 +
[srs14] [15/21] Upgrading subversion from 1.9.7_4 to 1.10.0...
 +
[srs14] [15/21] Extracting subversion-1.10.0: 100%
 +
[srs14] [16/21] Upgrading py27-setuptools from 39.0.1 to 39.2.0...
 +
[srs14] [16/21] Extracting py27-setuptools-39.2.0: 100%
 +
[srs14] [17/21] Upgrading neovim from 0.2.2_1 to 0.2.2_2...
 +
[srs14] [17/21] Extracting neovim-0.2.2_2: 100%
 +
[srs14] [18/21] Upgrading libidn2 from 2.0.4 to 2.0.5...
 +
[srs14] [18/21] Extracting libidn2-2.0.5: 100%
 +
[srs14] [19/21] Upgrading git from 2.16.3 to 2.17.1...
 +
===> Creating groups.
 +
Using existing group 'git_daemon'.
 +
===> Creating users
 +
Using existing user 'git_daemon'.
 +
[srs14] [19/21] Extracting git-2.17.1: 100%
 +
[srs14] [20/21] Upgrading bash from 4.4.19 to 4.4.23...
 +
[srs14] [20/21] Extracting bash-4.4.23: 100%
 +
[srs14] [21/21] Upgrading apache24 from 2.4.33 to 2.4.33_1...
 +
===> Creating groups.
 +
Using existing group 'www'.
 +
===> Creating users
 +
Using existing user 'www'.
 +
[srs14] [21/21] Extracting apache24-2.4.33_1: 100%
 +
You may need to manually remove /usr/local/etc/apache24/extra/httpd-vhosts.conf if it is no longer needed.
 +
You may need to manually remove /usr/local/etc/apache24/httpd.conf if it is no longer needed.
 +
Message from git-2.17.1:
 +
 
 +
------------------------------------------------------------------------
 +
*************************** GITWEB *************************************
 +
If you installed the GITWEB option please follow these instructions:
 +
 
 +
In the directory /usr/local/share/examples/git/gitweb you can find all files to
 +
make gitweb work as a public repository on the web.
 +
 
 +
All you have to do to make gitweb work is:
 +
1) Please be sure you're able to execute CGI scripts in
 +
  /usr/local/share/examples/git/gitweb.
 +
2) Set the GITWEB_CONFIG variable in your webserver's config to
 +
  /usr/local/etc/git/gitweb.conf. This variable is passed to gitweb.cgi.
 +
3) Restart server.
 +
*************************** GITWEB *************************************
 +
 
 +
*************************** CONTRIB ************************************
 +
If you installed the CONTRIB option please note that the scripts are
 +
installed in /usr/local/share/git-core/contrib. Some of them require
 +
other ports to be installed (perl, python, etc), which you may need to
 +
install manually.
 +
*************************** CONTRIB ************************************
 +
------------------------------------------------------------------------
 +
Message from apache24-2.4.33_1:
 +
 
 +
To run apache www server from startup, add apache24_enable="yes"
 +
in your /etc/rc.conf. Extra options can be found in startup script.
 +
 
 +
Your hostname must be resolvable using at least 1 mechanism in
 +
/etc/nsswitch.conf typically DNS or /etc/hosts or apache might
 +
have issues starting depending on the modules you are using.
 +
 
 +
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
 +
 
 +
- apache24 default build changed from static MPM to modular MPM
 +
- more modules are now enabled per default in the port
 +
- icons and error pages moved from WWWDIR to DATADIR
 +
 
 +
  If build with modular MPM and no MPM is activated in
 +
  httpd.conf, then mpm_prefork will be activated as default
 +
  MPM in etc/apache24/modules.d to keep compatibility with
 +
  existing php/perl/python modules!
 +
 
 +
Please compare the existing httpd.conf with httpd.conf.sample
 +
and merge missing modules/instructions into httpd.conf!
 +
 
 +
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
 +
!-->
 +
* ...
 +
 
 +
== Einschränkung auf Domain auf unsere eigene übliche ==
 +
 
 +
regex die alles ausschließt, wenn nicht nach @ mindestens noch ''stura.htw-dresden.de'' folgt
 +
<pre>
 +
^(?!.*[@.]stura\.htw-dresden\.de)
 +
</pre>
 +
 
 +
sudo ./bin/config_list -i <(echo 'ban_list = [ "^(?!.*[@.]stura\.htw-dresden\.de)", ]' ) intern
 +
 
 +
== message_size_limit ist begrenzend gesetzt (und verhindert das Annehmen von (besonders großen) Mails)  ==
 +
 
 +
voreinstellung (default) ist bestimmt (noch) aktiv
 +
<pre>
 +
message_size_limit = 10240000
 +
</pre>
 +
 
 +
(bei gelegenheit mal) prüfen
 +
<code>postconf -d</code>
 +
 
 +
vielleicht deaktivieren durch
 +
<pre>
 +
message_size_limit = 0
 +
</pre>
 +
 
 +
: btw: es wird vielleicht bald eine andere (von grund auf neu erstellte) instanz für mail geben.
 +
 
 +
--[[Benutzer:PaulRiegel|Paul]] 17:12, 20. Jul. 2018 (CEST)
 +
 
 +
----
 +
 
 +
<code>postconf -e 'message_size_limit = 0'</code>
 +
 
 +
== diff freebsd-version ==
 +
 
 +
; <code>[root@nyx ~]#</code>: <code>freebsd-version</code>
 +
<pre>
 +
11.1-STABLE
 +
</pre>
 +
; <code>root@srs14:/ #</code>: <code>freebsd-version</code>
 +
<pre>
 +
11.0-RELEASE-p1
 +
</pre>
 +
; <code>[root@nyx ~]#</code>: <code>jexec srs14 freebsd-version</code>
 +
<pre>
 +
11.0-RELEASE-p1
 +
</pre>
 +
 
 +
== {daily,weekly} output ==
 +
 
 +
<code>$EDITOR /etc/crontab</code>
 +
 
 +
== pkg update -f meldet Fehler wegen "OS dismatch" ==
 +
 
 +
; done!: 2018-10-09
 +
 
 +
<code>$EDITOR /usr/local/etc/pkg/repos/FreeBSD.conf</code>
 +
<pre>
 +
FreeBSD: {
 +
  url: "pkg+http://pkg.freebsd.org/FreeBSD:11:amd64/release_1/",
 +
  mirror_type: "srv",
 +
  enabled: yes
 +
}
 +
</pre>
 +
 
 +
== Erweiterung des vertrauenswürdigen "eigenen" Netzwerks auf die Bereich an Adresse für IPv4 auf die gesamte Hochschule  ==
 +
 
 +
[[Server/srs14#Konfiguration Postfix]]
 +
 
 +
in
 +
''/usr/local/etc/postfix/main.cf''
 +
bei
 +
<pre>
 +
mynetworks =
 +
</pre>
 +
<code>141.56.0.0/16</code>
 +
mit
 +
<code>, </code>
 +
hinzufügen?

Aktuelle Version vom 4. Juni 2021, 18:15 Uhr

Aktualisierung der installierten Paket (insbesondere auch aus den Ports)[Bearbeiten]

https://www.freebsd.org/doc/handbook/ports-using.html

sudo portsnap fetch
sudo portsnap update

Verwenden wir ein (bestimmtes) Werkzeug zur Verwaltung der Pakete (insbesondere auch aus den Ports)? (freshports:ports-mgmt/portmaster , freshports:ports-mgmt/portupgrade, freshports:ports-mgmt/synth oder andere bekannte gute Lösung?) Sollten wir es vielleicht richtig richtig machen und freshports:ports-mgmt/poudriere oder eine andere bekannte gute Lösung verwenden?

--Paul 17:58, 4. Jun. 2018 (CEST)


v bat PT sich dazu unverzüglich (2018-06-05 11:000 zu treffen. Es bleibt zu hoffen, dass da eine kurzfristige Lösung gefunden wird.

--Paul 18:01, 4. Jun. 2018 (CEST)

Problem der nicht passenden Referenz für die Version vom Kernel für die Pakete bei pkg[Bearbeiten]

done!


Ermitteln der Version vom aktuell verwendeten Kernel

uname -ku
1234567

Übliche Benutyung von pkg update, jedoch mit Angabe einer bestimmten Version vom (aktuell verwendeten) Kernel

pkg -o OSVERSION=1234567 update
upgrade -y

Vorbereitung zu CAPTCHA für Mailman[Bearbeiten]

recaptcha[Bearbeiten]

No!

Achtung! Es handelt sich um Dienst, der von google angeboten wird.

pkg install -y py27-recaptcha
pkg install -y py27-pycrypto

Aktualisierung der installierten Paket 2018-06-04[Bearbeiten]

  • jail gestoppt
  • snapshot datasets (alle 4 relevanten)
  • jail gestartet
sudo pkg update && pkg upgrade -y

  • jail neugestartet


pkg update -f


sudo pkg upgrade -y

  • ...

Einschränkung auf Domain auf unsere eigene übliche[Bearbeiten]

regex die alles ausschließt, wenn nicht nach @ mindestens noch stura.htw-dresden.de folgt

^(?!.*[@.]stura\.htw-dresden\.de)

sudo ./bin/config_list -i <(echo 'ban_list = [ "^(?!.*[@.]stura\.htw-dresden\.de)", ]' ) intern

message_size_limit ist begrenzend gesetzt (und verhindert das Annehmen von (besonders großen) Mails)[Bearbeiten]

voreinstellung (default) ist bestimmt (noch) aktiv

message_size_limit = 10240000

(bei gelegenheit mal) prüfen postconf -d

vielleicht deaktivieren durch

message_size_limit = 0
btw: es wird vielleicht bald eine andere (von grund auf neu erstellte) instanz für mail geben.

--Paul 17:12, 20. Jul. 2018 (CEST)


postconf -e 'message_size_limit = 0'

diff freebsd-version[Bearbeiten]

[root@nyx ~]#
freebsd-version
11.1-STABLE
root@srs14:/ #
freebsd-version
11.0-RELEASE-p1
[root@nyx ~]#
jexec srs14 freebsd-version
11.0-RELEASE-p1

{daily,weekly} output[Bearbeiten]

$EDITOR /etc/crontab

pkg update -f meldet Fehler wegen "OS dismatch"[Bearbeiten]

done!
2018-10-09

$EDITOR /usr/local/etc/pkg/repos/FreeBSD.conf

FreeBSD: {
  url: "pkg+http://pkg.freebsd.org/FreeBSD:11:amd64/release_1/",
  mirror_type: "srv",
  enabled: yes
}

Erweiterung des vertrauenswürdigen "eigenen" Netzwerks auf die Bereich an Adresse für IPv4 auf die gesamte Hochschule[Bearbeiten]

Server/srs14#Konfiguration Postfix

in /usr/local/etc/postfix/main.cf bei

mynetworks =

141.56.0.0/16 mit , hinzufügen?